hosting.com
← Back to status

KWE limited support availability

Resolved Jul 7, 2026 05:22 CST

Incident Updates

  • Recovering Jul 7, 2026 05:22 CST

    Please be advised that our Kenyan Support Team will be limited today due to un-planned demonstrations for safety reasons. During this time, clients may experience slightly longer-than-usual response times through our support channels. We sincerely appreciate your patience and understanding while we complete this internal event.