hosting.com
← Back to status

Outgoing email Issues

Resolved Apr 29, 2025 10:01 CST

Incident Updates

  • Resolved Apr 29, 2025 11:10 CST

    We've now resolved the incident. Thanks for your patience.

  • Resolved Apr 29, 2025 10:01 CST

    We are aware of an issue with multiple servers having outgoing email issues. Error: (mailchannels_smtp defer (-54): retry time not reached for any host) Our engineering team is actively analyzing the issue across affected servers and are working on a fix as a priority. Thank you for your patience.