hosting.com
← Back to status

My.hosting.com issue

Resolved May 20, 2025 15:37 CST

Incident Updates

  • Resolved May 20, 2025 20:39 CST

    Update - this is now resolved. Apologies for the inconvenience cause. The issue was within Google Cloud's network, which we utilise for our my.hosting.com panel. Our own networks and servers were unaffected.

  • Resolved May 20, 2025 15:37 CST

    We're currently investigating an issue with our my.hosting.com panel showing an error page - apologies for the inconvenience. Please bear with us. Please note this does *not* affect any running servers or websites as our panel is hosted separately to our customer systems.