hosting.com
← Back to status

Update – Intermittent Website Access on mi3-ss3.a2hosting.com

Resolved May 21, 2025 23:32 CST

Incident Updates

  • Resolved May 22, 2025 22:17 CST

    We've now resolved the incident. Thanks for your patience.

  • Resolved May 21, 2025 23:32 CST

    Our infrastructure team has identified some users may be experiencing intermittent issues when accessing websites hosted on mi3-ss3.a2hosting.com. We understand how important these services are and sincerely appreciate your patience. Our team is continuing to monitor the situation closely to ensure full resolution.