Kenya Website Experts joining hosting.com
Incident Updates
-
Resolved Jun 21, 2025 12:59 CST
Welcome! Kenya Website Experts is now part of hosting.com - you can log in to your account at https://my.hosting.com with the same login details as before. Our support team in Nairobi are on hand to help you with any issues!
-
Resolved Jun 21, 2025 10:03 CST
Data is imported and we are running final checks on data quality before enabling logins and access.
-
Resolved Jun 20, 2025 14:38 CST
We still have a few thousand clients still to import which we expect will take around 8 hours. Logins should be enabled overnight tonight.
-
Resolved Jun 19, 2025 19:56 CST
KWE is now in maintenance mode as services are being migrated to hosting.com. No disruption to websites or domains whatsoever.
-
Resolved Jun 18, 2025 21:46 CST
Background details at https://hosting.com/kenya-web-experts/
-
Resolved Jun 18, 2025 21:45 CST
This migration is now underway and data is being prepared. The current Kenya Website Experts client area remains online but is closed to new clients. Existing clients can log in and manage their account and order new services. New clients should order directly at hosting.com/kenya-web-experts.