Kenyan Phone Support Offline
Resolved
Jun 25, 2025 09:28 CST
Incident Updates
-
Resolved Jul 1, 2025 07:35 CST
This incident is now resolved. Thanks for your patience and understanding
-
Resolved Jun 25, 2025 09:28 CST
Due to ongoing protests in Kenya, our Nairobi office is closed today for the safety of our team. As a result, Kenyan phone and WhatsApp support are temporarily unavailable. Our global support team remains fully operational and available 24/7 via live chat and support tickets. We appreciate your understanding and patience during this time.