Server Incident Report
Resolved
Aug 29, 2025 17:41 CST
Incident Updates
-
Resolved Aug 29, 2025 19:09 CST
We've now resolved the incident. Thanks for your patience.
-
Resolved Aug 29, 2025 17:41 CST
The Apache web server service is currently down on the server mi3-cl9-isr1.a2hosting.com. Our team is actively checking the issue. Further updates will be provided as soon as more information is available. Please contact our support team if you are having issues.