Email server issue - mx3594.syd1.mymailhosting.com
Resolved
Nov 25, 2025 10:04 CST
Incident Updates
-
Resolved Nov 25, 2025 10:31 CST
We've now resolved the incident. Thanks for your patience.
-
Resolved Nov 25, 2025 10:04 CST
We are aware of a few customers experiencing intermittent disruptions to our email services on mx3594.syd1.mymailhosting.com due to an issue affecting admin logins. Our team is currently investigating and working on this as a priority. We will provide further updates as more information becomes available. If you require immediate help, please contact our Customer Care Team.