Service Incident Report mi3-tr103.a2hosting.com
Resolved
Dec 15, 2025 20:35 CST
Incident Updates
-
Resolved Dec 15, 2025 21:02 CST
We've now resolved the incident. Thanks for your patience.
-
Resolved Dec 15, 2025 20:35 CST
We are currently investigating reports of load on mi3-tr103.a2hosting.com. Impact: Customers hosted on this server may experience slow page loads, timeouts, or database connection errors. Current Action: Our System Operations team has identified the high load and is actively investigating the root cause to restore stability