hosting.com
← Back to status

Hardware Connectivity Issues - Some Servers

Resolved Mar 10, 2026 21:30 CST

Incident Updates

  • Resolved Mar 10, 2026 21:39 CST

    We've now resolved the incident. Thanks for your patience.

  • Resolved Mar 10, 2026 21:30 CST

    We are currently experiencing a critical service interruption due to a sudden loss of power at the hardware level. This issue is impacting all hosted services across some servers within the affected segment. We are currently inspecting power distribution units and backup systems to restore connectivity as quickly as possible.