Password reset and email verification delays
Resolved
Apr 22, 2026 09:58 CST
Incident Updates
-
Resolved Apr 28, 2026 23:55 CST
After a careful monitoring period, we would like to thank our clients for the patience they've had whilst our team was working on this resolution and apologize for any inconvenience caused. If you have further issues please don't hesitate to contact us, were are here 24/7 and always ready to assist.
-
Resolved Apr 27, 2026 21:11 CST
We've fixed the core issue, and are waiting for things to recover.
-
Resolved Apr 22, 2026 09:58 CST
We are aware of a few customers experiencing some delays when receiving password reset email and verification emails. Our infrastructure team are working on this as a priority to resolve this matter. If you need any assistance in the immediate, please reach out to our support team.