hosting.com
← Back to status

High Load Causing Slow Site Loading

Resolved Apr 28, 2026 15:36 CST

Incident Updates

  • Resolved Apr 28, 2026 15:49 CST

    We've now resolved the incident. Thanks for your patience.

  • Resolved Apr 28, 2026 15:36 CST

    We are currently investigating reports of high server load affecting mi3-tr102.supercp.com. Some websites hosted on this server may be loading very slowly or timing out. Our team is checking the server and working to restore normal performance as soon as possible.