hosting.com
← Back to status

KWE limited support availability

Resolved Jun 25, 2026 06:08 CST

Incident Updates

  • Resolved Jun 26, 2026 05:22 CST

    Our support team is back online and functioning as normal. We would like to thank you for your patience during this time. Please don't hesitate to contact us if you have any questions or need assistance with your services.

  • Resolved Jun 25, 2026 06:08 CST

    Please be advised that our Kenyan Support Team will be limited today due to planned demonstrations for safety reasons During this time, clients may experience slightly longer-than-usual response times through our support channels. We sincerely appreciate your patience and understanding while we complete this internal event.